不学网

 找回密码
 立即注册

手机号码,快捷登录

查看: 291|回复: 0

[python] Python3.6下scrapy框架的安装

[复制链接]
Ricardo 发表于 2018-6-30 17:10:52 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
首先考虑使用最简单的方法安装
  1. pip install scrapy
复制代码
命令安装,提示

Failed building wheel for Twisted

Microsoft Visual C++ 14.0 is required...

于是开始问度娘应该怎样安装,看了几篇博客,虽然和我的问题不十分相同,但是也受到了启发,知道应该怎样解决我的问题了。解决问题的过程总结如下:

1、直接使用pip install scrapy安装不成功可以安装whl格式的包

首先下载scrapy的whl包

下载地址:[url]http://www.lfd.uci.edu/~gohlke/pythonlibs/[/url]

在网页中搜索scrapy找到Scrapy‑1.3.3‑py2.py3‑none‑any.whl下载了scrapy的whl包先不要着急安装,接着
2、安装whl格式包需要安装wheel库
看到别人的博客上说可以直接使用pip install wheel安装wheel,由于我已经安装过wheel了,在这里就不用安装了,就没有测试怎么安装wheel。
没有安装过wheel库的请先安装。
3、scrapy依赖twiste,同样使用whl格式的包进行安装
还是进入http://www.lfd.uci.edu/~gohlke/pythonlibs/,在网页中搜索twisted找到其对应的whl包并下载
  • Twisted‑17.1.0‑cp36‑cp36m‑win_amd64.whl
根据你的Python的版本选择合适的包,名称中间的cp36是python3.6的意思,amd64是python的位数
下载完成后使用cmd打开windows的命令行窗口,进入whl包所在的文件夹执行如下命令
  1. pip install [whl]
复制代码
[whl]是whl包的名字,即:
  1. pip install Twisted-17.1.0-cp36-cp36m-win_amd64.whl
复制代码
6152595-4ac91c20904c52f9.png
Scrapy-1.3.3-py2.py3-none-any.whl包使用同样的方式安装,只是应该等到其所有依赖的包安装完成后才能进行安装,现在还不能安装

4、scrapy依赖lxml包,需要先安装lxml包,lxml包依赖libxml2,libxml2-devel,所以安装lxmllibxml2, libxml2-devel。幸运的是之前我之前已经安装过lxml

5、所有准备工作做完,终于可以安装scrapy包了,进入Scrapy-1.3.3-py2.py3-none-any.whl所在的目录

  1. pip install Scrapy-1.3.3-py2.py3-none-any.whl
复制代码
6152595-4ac91c20904c52f9.png
Successfully ! 先别急着撒花,是否真的安装成功了,还需要验证,输入scrapy -h

显示scrapy的相关信息,大功告成,撒花~~~

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|不学网

GMT+8, 2018-9-26 18:20

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表